Some ‘Brief’ Issues

Posted: Saturday, March 20, 2010 by El Guru in Add-ons, Blogs, Firefox, Fx 3.5, Fx 3.6, Fx 3.7, Thunderbird

First off this post has nothing to do with underwear but rather Brief – feed reading extension for Firefox. I’ve been using this extension to handle all my RSS feeds for quite some time and never really had problems. Then a while back I started to notice that even though I have it set to automatically check for new feeds about every 10-minutes it wasn’t. Further when I opened Brief in a tab I would notice the progress bar was stalled at around 95%. If I pressed the ‘stop’ button and then did a manual check, it would work fine. Further, it didn’t always ‘stall’, sometimes it would work fine for hours or days.

To fix this issue I have I tried uninstalling then and re-installing the add-on; wiped out my Feeds folder and re-setup all my feeds. No change. Back when I first started having this issue I had checked the developers site and that time I didn’t see anything related to the issue I was experiencing. I decided early this morning I was either going to look for a new reader as I was missing (more like getting late) Firefox/Thunderbird news and even some of the non-Mozilla related feeds.

Whilst I know Thunderbird can handle RSS feeds, I prefer to keep my Thunderbird just for handling my four IMAP email accounts. What I like about Brief is I can read most feeds (some only sites only publish excerpts to their feeds) within the add-on without having to leave the tab. Yes, I could use Live Bookmarks which are nice, but you still have to check to see if there is an update.

I checked again on the Brief developer’s site and this in the forum I found the thread Time relaod stops working. Well, after reading the first post I determined this was indeed what was happening to my Brief as well. The developers suggested trying to install version 1.5 (which is still in Beta) to see if that fixes the issue. The thread was started at the end of January and there had mixed success reported and even some new issues with duplicate entries. I went ahead and installed version 1.5 and so far it seems to be behaving fine and I have no issues with duplicate entries.

Comments
  1. Will says:

    Only time I ever have that issue is when there is an error in one of the RSS feeds itself. NeoWin.net does it a lot it seems.

    If it happens again open up the Error Console from Tools and see if any errors are generated when you load up the feeds.

  2. Jeff says:

    I have had the exact same experience that you describe. I also have had problems with certain feeds (like http://www.thenation.com) refusing to update, although it works fine in T-bird. This started around the time of the 3.6 update.

  3. YU says:

    How to use it?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s