Disable Apostrophe Opening QuickFind Bar

Posted: Tuesday, September 2, 2008 by El Guru in Add-ons, Firefox, Fx 1.5, Fx 2.0, Fx 3.0, Tips & Tweaks

In theory, the Quick Find bar should not activate when pressing the apostrophe (‘) and slash (/) keys when you are in a text-box. However, many users have reported that the Quick Find bar does activate when pressing the apostrophe (‘) and slash (/) keys even if they are in a text-box. There is an extension called SearchHotKeys that will disable the apostrophe (‘) and slash (/) keys from invoking the quick find bar. You can still invoke via CTRL+F. This should work for Firefox 2 and 3*. Follow these steps below:

  1. Go to http://www.nic-nac-project.org/~kaosmos/index-en.html#searchkeys
  2. Right-click and select ‘Save Link As…’ on the link for your version of Firefox (1.5/2.0/3.0)
  3. Make a note where you are saving the extension (hint: save to desktop)
  4. Open the add-ons manager via Tools, Add-ons
  5. Locate the file you downloaded in Step 3 and drag into the Add-ons Manager window to install
  6. Restart Firefox
  7. Open a new tab and in the address bar type about:config
  8. Click I’ll Be Careful, I Promise on the  ‘This Gun Is Loaded’ or ‘Void Your Warranty’ or any other warning
  9. In the Filter field type searchkeys.disable.all
  10. Doubleclick on entry to switch value to True

*Note with Firefox 3 you may not need to do steps 7-10 as it seems to automatically disable by default.

Update: 02/21/09 new link

Comments
  1. Argh says:

    This would be fine if I didn’t have any use for the QuickFind bar, but I do. How do I make it work on web pages but not inside rich text inputs?

  2. […] to add: I found a fix to the apostrophe opening the quickfind box here. Now I just need to get the arrow keys […]

  3. […] You can find the fix here, but I’ll give the summary. You got to install an Add-On (which is really just a cheat so you don’t have to do a bunch of hand coding yourself). If you’re lucky, that’s it. If you’re unlucky like me, then you also got to change a setting in the deep level config file. Plus make sure you undo a “fix” from another message board that, in fact, does the exact opposite of what you want to do (the correct setting is to uncheck the Search-For-Text box in the Tools>Options>Advanced>General settings). 1 hour and a few choice words later, I can now blog again. […]

  4. monkeybrain says:

    Praise be! I was going to lose my mind if this didn’t fix it.. Thank you!

  5. Pat Gunn says:

    It looks like they moved their site from a .DE to a .ORG – the extension is now at:
    http://www.nic-nac-project.org/~kaosmos/index-en.html#searchkeys

  6. Katherine says:

    Thank you so much! I was going nuts, particularly since I use Yahoo mail and I couldn’t use the ‘ without activating quick search.

  7. Matt Martin says:

    Thank you!!!!!!!!!!!!!! That was driving me nuts but this worked like a charm!!!

    • Lange Fischer says:

      Just want to write to say thank you. Like everyone else who posted here, I was slowly being driven nuts but how formal my emails were sounding. Simple fix and worked flawlessly so far.

      Thanks,

  8. Midnight says:

    Oh thank you so much! This has help greatly; indeed it has!

  9. Cascade Lily says:

    I love you! Thank you so much. I too was going nuts and thinking about *sob* giving up Firefox before I found your solution!

  10. Meetloaf13 says:

    Oh man…LIFESAVER, I was going CRAZY

  11. Kricket says:

    For heavens sake, I have gone through the routine numerous times trying to get FireFox to disable that Quick Find nonsense once and for all – seems when I do it it works for awhile then Quick Find comes back – I don’t want to have to do this every time I come in to use my email. If you disable it it should stay disabled! This is making me angry! I need to know what to do to stop it for good or, sadly, will have to find another internet provider because this is a royal pain & total annoyance!

  12. JWilson says:

    As everyone else has said, THANK YOU!!!!!!!

  13. Steve says:

    Just did the install for FF 3.5.7 and it all worked great… and as you guessed, no need for items 7 to 10.

  14. JN says:

    Thanks. Worked perfectly.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s